Overheating issue....tried everything !!!!!!!

Radiator, thermostat, water pump, antifreeze, etc.
Post Reply

Topic author
sieng123
I am merely driving my van
I am merely driving my van
Posts: 2
Joined: Sat Apr 13, 2024 4:55 pm

Overheating issue....tried everything !!!!!!!

Post by sieng123 »

Hello everyone. I have a 1999 safari with 300,000 km on it. I have an overheating issue. I'll start my story from a long time ago. I'm in Canada and I only drive this van in the winter, I put about 5000 km on in the winter and then it sits all summer. About five years ago I noticed it wasn't blowing as much heat as it use to so I changed the heater core, it didn't help. So over the past 4 winters I've noticed it giving less heat every winter, not heating up to operating temp when I start it in the morning to let it warm up, even when the air temp here in Calgary is around the freezing mark, it just would not come up to operating temp. The only way to get the temp up was to take it out on the highway. Just this last winter the running too cold problem turned into a overheating issue where I couldn't even drive it down the street without it overheating, also at this time it blows no warm air out the vents at all, only cold. Over these past 4 years I have changed the heater core, heater control valve, thermostat 3 times thinking the first 2 were faulty I finally put in an AC delco, changed the water pump, just did the head gaskets thinking it was pressurizing the system, and also just put in a new rad when the head gaskets didn't help. There's nothing in the system left to replace. Does anyone have any ideas what the issue could be? Thanks.
User avatar

MountainManJoe
I have my van tatooed on my cheeks
Posts: 3128
Joined: Fri Aug 08, 2008 12:55 pm
Location: The Pacific North Wet
Has thanked: 47 times
Been thanked: 25 times

Re: Overheating issue....tried everything !!!!!!!

Post by MountainManJoe »

Hi welcome to the forum.
Does the fan run when the temp gets hot?

Topic author
sieng123
I am merely driving my van
I am merely driving my van
Posts: 2
Joined: Sat Apr 13, 2024 4:55 pm

Re: Overheating issue....tried everything !!!!!!!

Post by sieng123 »

Thank You for the welcome. I've never noticed if it ran when hot. I don't think so, I mean the van now idles in my driveway for 5 minutes and the temp guage is already in the red zone and I don't think the fan clutch kicks in. I did also replace the fan clutch about 10,000 km ago.
User avatar

MountainManJoe
I have my van tatooed on my cheeks
Posts: 3128
Joined: Fri Aug 08, 2008 12:55 pm
Location: The Pacific North Wet
Has thanked: 47 times
Been thanked: 25 times

Re: Overheating issue....tried everything !!!!!!!

Post by MountainManJoe »

It should be coming on full blast.
Try the troubleshooting here: https://charm.li/Chevy%20Truck/1999/Ast ... erheating/
Post Reply