Instrument cluster lights and gauges go on and off while driving

General technical discussion and troubleshooting
Post Reply

Topic author
Bgrahovac
I am merely driving my van
I am merely driving my van
Posts: 1
Joined: Mon May 27, 2024 6:23 am

Instrument cluster lights and gauges go on and off while driving

Post by Bgrahovac »

Hello all, new here and have an issue I need help with. Maybe someone has experienced this as well...

2005 Express 2500 6.0 gas engine. Yesterday while almost immediately on start up the cluster lights all came on and the gauge needles dropped off. It would do this while driving staying off and on for a maybe 5-30 seconds and then come back and go out.

The day before I replaced the A/C compressor and both belt tensioners. I was in the fuse box using a paper clip to jump the compressor clutch to fill the A/C system. I also replaced the washer fluid pump.

I know I should most likely start with checking fuses, etc. Has anyone else experienced this issue? The van was literally fine before I did the work. I did have to remove a braided strap group that goes from engine to the frame in order to remove the a/c compressor. I put it back on in the same position but it's not in the greatest shape and is a beautiful shade of green lol

Any help would be appreciated! This van has to make a trip to Pittsburgh from Cleveland next weekend.
User avatar

MountainManJoe
I have my van tatooed on my cheeks
Posts: 3141
Joined: Fri Aug 08, 2008 12:55 pm
Location: The Pacific North Wet
Has thanked: 48 times
Been thanked: 25 times

Re: Instrument cluster lights and gauges go on and off while driving

Post by MountainManJoe »

Welcome to the forum
Bgrahovac wrote: Mon May 27, 2024 6:32 am it's not in the greatest shape and is a beautiful shade of green lol
I would start with replacing that.
Post Reply