Battery not charging

Battery, alternator, starter, cables, etc.
User avatar

Topic author
justice
I sleep in my van
Posts: 875
Joined: Wed Dec 31, 1969 4:00 pm
Location: Keeping a good eye on all you yahoos

Battery not charging

Post by justice »

On the 1992, the volt guage in the dash is showing 12 volts when running. Battery shows 12.55 volts at idle, no change when running. (tested with volt meter)

I pulled the alternator and had it tested and it passed. I'm not sure where else to look right now.

I verified that I have continuity from the alt to the battery via the large red wire, but i have no idea how to test the other wires in the plug that also attaches to the alt..

I recently had a new computer and O2 sensor installed. Old computer was bad. There have been no other changes to the van.

help.
I have a ban hammer and I ain't fraid to use it!


Current - 2004 Astro Cargo


Former
95 Safari (money pit - sold)
93 Astro Cargo (totaled)
85 Astro - (Bought for parts and scrapped)
92 Astro Conversion (sold)
87 Safari Shorty (sold)
User avatar

Kabey's Van
I sleep in my van
Posts: 682
Joined: Mon Sep 29, 2008 8:35 am
Location: Victoria B.C.

Re: Battery not charging

Post by Kabey's Van »

Clean up or replace your "big three" and see if there is a difference.
At 12.55 it's picking up a bit of a charge, so I am thinking its a bad connection or wire somewhere. Check all your grounds, upgrade them to a heavier wire if you wish. A poor ground willl wreak havoc on an electrical system.

Peter

Cobra
ASV Supporter
ASV Supporter
Posts: 1750
Joined: Sat Jun 16, 2007 2:31 pm
Location: Toronto, Ontario
Been thanked: 1 time

Re: Battery not charging

Post by Cobra »

i've had an alternator not charge and test good turned out to be a loose connection inside the alternator, but i'm with Kabey 12.55 seems like a strange number to me
1998 GMC Safari AWD, BFGoodrich AllTerrain T/A
Jet performance tuner 91 octane preset, Jet under-drive pulleys
Rancho 999000 series shock, on-board controller to be installed later
DHC rock rails and skid plate Add-A-Leaf
G3500 front calipers
Zexel Torsen Diff
11" drums
180 amp Alternator
Long tru-cool 4590 trans cooler

1997 in storage (project coming soon)
User avatar

Topic author
justice
I sleep in my van
Posts: 875
Joined: Wed Dec 31, 1969 4:00 pm
Location: Keeping a good eye on all you yahoos

Re: Battery not charging

Post by justice »

FWIW, i did replace the alt and the replacement did the same thing as the old one. I took it back and had them BOTH tested (new and old) both were OK. Got my money back and stuck the old one back in.

My mechanic tells me to check the wiring at the starter to see if there is a bad or broken wire there.
I have a ban hammer and I ain't fraid to use it!


Current - 2004 Astro Cargo


Former
95 Safari (money pit - sold)
93 Astro Cargo (totaled)
85 Astro - (Bought for parts and scrapped)
92 Astro Conversion (sold)
87 Safari Shorty (sold)
User avatar

Topic author
justice
I sleep in my van
Posts: 875
Joined: Wed Dec 31, 1969 4:00 pm
Location: Keeping a good eye on all you yahoos

Re: Battery not charging

Post by justice »

just crawled under the van to try to look st the starter. from what I can see, there are 4 wires going to the starter.

The main wire from the battery.

A red wire with what looks like a fuse on it.

A purple wire

and a fourth wire that looks like it is yellow, but has a fuse looking thing on it and on the other side of the fuse the wire looks black or brown with a stripe. This wire is definitly broken between the fuse and whereever it attaches on the starter. I will have to drop the starter to find out exactly where it goes.

strangely, my wiring diagram only shows 3 wires going to the starter, red, purple and black.
I have a ban hammer and I ain't fraid to use it!


Current - 2004 Astro Cargo


Former
95 Safari (money pit - sold)
93 Astro Cargo (totaled)
85 Astro - (Bought for parts and scrapped)
92 Astro Conversion (sold)
87 Safari Shorty (sold)
User avatar

1Gary
I have my van tatooed on my cheeks
Posts: 2743
Joined: Wed Oct 07, 2009 4:18 am

Re: Battery not charging

Post by 1Gary »

Dow-anyone do a aftermarket remote start on your van??. :-k
1979 Malibu drag race only car
1999 Sonoma 4.3 5 speed-Rufus
1989 Astro-Ole Yellar cancelled-still selling off parts
1985 Astro-shop van R.I.P. my friend
1994 Astro LT RWD W4.3 rod knock RIP
1982 Winnebago single rear wheel-Chevy 350 Scraped 1/28/13-broken dreams......


Rochester,NY
User avatar

Topic author
justice
I sleep in my van
Posts: 875
Joined: Wed Dec 31, 1969 4:00 pm
Location: Keeping a good eye on all you yahoos

Re: Battery not charging

Post by justice »

1Gary wrote:Dow-anyone do a aftermarket remote start on your van??. :-k
no, but it did have a non working alarm when i bought it, but it was removed years ago.
I have a ban hammer and I ain't fraid to use it!


Current - 2004 Astro Cargo


Former
95 Safari (money pit - sold)
93 Astro Cargo (totaled)
85 Astro - (Bought for parts and scrapped)
92 Astro Conversion (sold)
87 Safari Shorty (sold)

LiftedAWDAstro
I have my van tatooed on my cheeks
Posts: 4379
Joined: Sat Sep 09, 2006 3:35 pm
Location: New Haven, NY

Re: Battery not charging

Post by LiftedAWDAstro »

You will want to pull those connections apart and clean them well. One of those wires is the charge line from the alternator unless you have done the "big 3".
Current rides:
2013 Toyota Tundra DC 4x4
2008 Dodge Nitro 4x4
2005 Nissan Sentra 1.8S Special Edition

Mileage spreadsheet

Vans owned:
1986 Safari 2.5L 4 speed manual - scrapped
1995 Astro 2WD conversion 4.11 posi, shift kit, DHC rock rails - sold to Skippy
1998 Astro 4x4 D44, D60, NP231, full hydraulic system with 9k# Milemarker winch and snow plow - sold to Lockdoc
2003 Astro AWD all stock - traded for a 3/4 ton truck
2005 AWD, 4.10's - sold to skippy

Kidhauler
I sleep in my van
Posts: 877
Joined: Wed Sep 13, 2006 5:46 pm
Location: Vancouver B.C.

Re: Battery not charging

Post by Kidhauler »

From the "fuse" looking thing to the starter is whats called a fuseable link. Basicly in the event of a short the last 6 inches of the wire is desinged to burn up. If the wire looks broken or damaged it is possible that the inside of the wire is burnt out and you are left with just a empty case. I had that happen on my 89 a few years ago it took me a while to find. I just went to the wreckers and pulled a wire from a junk van so that the fusable link section would be the correct length.
1999 Safari Touring edition.
trailer tow pack with a 3:73 posi
Bucket bench seats, Rear heat, Rear Airconditioning.
teal green
300 000 kms
AirRide air bags in the rear to fix soft stock suspension.
Onboard aircompressor to make it all work nice.
User avatar

reaper
I sleep in my van
Posts: 381
Joined: Thu Sep 21, 2006 8:51 pm
Location: VANcouver

Re: Battery not charging

Post by reaper »

Check the battery,If you can toss in another battery & check charge rate.
90 Astro Cargo V-8
90 Artro RS - V-8 Now running!
& a bunch of tractors
"there's nothing like a V-8 Polluting the Environment"
Image
User avatar

Topic author
justice
I sleep in my van
Posts: 875
Joined: Wed Dec 31, 1969 4:00 pm
Location: Keeping a good eye on all you yahoos

Re: Battery not charging

Post by justice »

its fixed. it was a combination of the blown fusable link and a blown fuse under the dash.
I have a ban hammer and I ain't fraid to use it!


Current - 2004 Astro Cargo


Former
95 Safari (money pit - sold)
93 Astro Cargo (totaled)
85 Astro - (Bought for parts and scrapped)
92 Astro Conversion (sold)
87 Safari Shorty (sold)

LiftedAWDAstro
I have my van tatooed on my cheeks
Posts: 4379
Joined: Sat Sep 09, 2006 3:35 pm
Location: New Haven, NY

Re: Battery not charging

Post by LiftedAWDAstro »

Cool. It's nice when it's a relatively easy fix.
Current rides:
2013 Toyota Tundra DC 4x4
2008 Dodge Nitro 4x4
2005 Nissan Sentra 1.8S Special Edition

Mileage spreadsheet

Vans owned:
1986 Safari 2.5L 4 speed manual - scrapped
1995 Astro 2WD conversion 4.11 posi, shift kit, DHC rock rails - sold to Skippy
1998 Astro 4x4 D44, D60, NP231, full hydraulic system with 9k# Milemarker winch and snow plow - sold to Lockdoc
2003 Astro AWD all stock - traded for a 3/4 ton truck
2005 AWD, 4.10's - sold to skippy
User avatar

1Gary
I have my van tatooed on my cheeks
Posts: 2743
Joined: Wed Oct 07, 2009 4:18 am

Re: Battery not charging

Post by 1Gary »

Good to hear you found it.
1979 Malibu drag race only car
1999 Sonoma 4.3 5 speed-Rufus
1989 Astro-Ole Yellar cancelled-still selling off parts
1985 Astro-shop van R.I.P. my friend
1994 Astro LT RWD W4.3 rod knock RIP
1982 Winnebago single rear wheel-Chevy 350 Scraped 1/28/13-broken dreams......


Rochester,NY
User avatar

silver mist AWD
I am merely driving my van
I am merely driving my van
Posts: 16
Joined: Sat Jun 25, 2011 1:19 am

Re: Battery not charging

Post by silver mist AWD »

Right after replacing my grill after trans cooler installation my idiot light for battery came on, guage shows 12v charging rate, usually it is 14 plus. I guess I will go with this information and proceed.
2000 AWD, 120k, dad first owner, regular maint, hiway miles, color silver mist. Before that I had a '94 for a while. (wait 'til I get the pics.) Had astros in the family since '91.

I Bought Dad's Chevy 3/4 ton when he bought astro. I grew up on the middle seat of '68 Dodge (great in winter, not summer). Brother got it when Dad bought the chevy in '76. Before that Greenbriar, I was a baby when it was doing camping trips to Colorado.

Toyota vanwagon years ago, loved it, wish it 4wd.

astroturf
ASV Supporter
ASV Supporter
Posts: 1658
Joined: Wed Sep 09, 2009 6:25 pm

Re: Battery not charging

Post by astroturf »

silver mist AWD wrote:Right after replacing my grill after trans cooler installation my idiot light for battery came on, guage shows 12v charging rate, usually it is 14 plus. I guess I will go with this information and proceed.
What electric device did you disconnect?

I would start simply at the battery cable.

Good Luck, Jim
Post Reply